To insert code in a forum thread or comment wrap it in code tags : <code>...</code>.
Blog - Display Read More not turning off for bloglist although I have set it so in the blog panel..
  • I turned off the "Display Read More" option under Blog, but it still shows. Any insight?
  • 9 Comments sorted by
  • Hi

    We have not had a problem with the read more button for the blog failing to turn off since Dec 2010. May I ask for confirmation of the Striking and wp versions you are using? Also a page link would be helpful, and is this on your main blog page or when you have input the blog shortcode to create a blog list somewhere else in your site, or both?

    In your blog shortcode, do you have the following as part of the shortcode:

    [blog imageType...... read_more="false"....]

    Also i recategorized your post - you left it in 'striking" which as per the forum guidelines, is a header category not to be used. I also added a more functional title.

    Best Regards
    Striking Team
    James
  • I am using the Wordpress default blog which calls the archive.php page. This can be found at http://go.htsdesigns.com/pianokeyz/?cat=1. Everything else I modified under Striking -> Blog worked on this page except for Read More. The specific code is:

    <div class="entry_content">
    <a class="read_more_link" href="xyz" rel="nofollow">Read more »</a>
    </div>


    Striking Version: 5.1.8.3
    Wordpress Version: 3.4.2

    Regards,
    Ben
  • Hi Ben

    I have to see this in order to fix this. However you can fix it also by css


    .category .entry .entry_content {display:none;}

    or for only that category

    .category-lessons .entry .entry_content {display:none;}

    Please put this custom css code into the custom css field of the striking general settings.

    if you want me to look at this pls send me admin login details.

    If you need any help on this can you grant me access to the admin part of your website?

    Just send me a private email with the login details to the admin.

    Click on my name and then on the left you can send me a private email.

    Please also include a link to this thread so i know what the personal mail is about.

    Best regards,
    Striking Team
    Paul
  • Thanks, that worked perfectly. However, there is still a 1px line under the title. Can this be removed as well?

    Thanks,
    Ben
  • Hi,

    You could try to turn off the meta data in the blog settings or



    .entry_frame {
    border-color: #FFFFFF !important;
    }


    Best regards,
    Striking Team
    Paul
  • Thanks. I added

    .entry_meta {display:none;}

    And that worked.

    Ben
  • Hi Ben

    I found another solution to the read more button problem. Just remove the text read more in the blog settings.

    We are going to look into this. Thanks for reporting.

    Best regards,
    Striking Team
    Paul
  • Sorry, but "remove the text read more in the blog settings" isn't working (as also the "display read more"-setting..).

    Moreover I would like to use the "read more"-link () instead of using excerpts - but this is also not working. On the blog page I'm always getting the same: an automatically created and text-limited excerpt (if there is no special excerpt).

    Any ideas? :-)
    Wolf
  • Ah, okay, found solution here:

    http://kaptinlin.com/support/discussion/2910/more-tag-doesnt-cut-the-excerpt-on-the-blog-or-homepage

    --------------there is said: ----------
    You can go to striking->blog options page to enable Display Full Blog Posts option.
    Then you can use more tag in the editor to cut the article.
    ------------------------------------

    This worked for me. :-)
This discussion has been closed.
All Discussions