To insert code in a forum thread or comment wrap it in code tags : <code>...</code>.
Clear Cache Warning after 5.1.8 update
  • I just upgraded Striking running on my localhost server (XAMPP version 1.7.7 + the latest stable WP version) to 5.1.8. If I toggle "Clear Cache" and click "Save Changes" I get a warning:

    Warning: Invalid argument supplied for foreach() in D:\Web\xampp\htdocs\test\wp-content\themes\km\framework\admin\options\theme_advance.php on line 25

    but also a message:

    All caches successfully emptied.
    Updated Successfully


    If I repeat the cache clearing I get the same warning but the message below says:

    Updated Successfully

    so I guess the cache is being cleared.

    Striking is placed under "wp-content\themes\km\" directory instead of wp-content\themes\striking\but that was never a problem. I use the following plugins:

    All in One SEO Pack
    Contact Form 7
    Gravity Forms
    Really Simple CAPTCHA
    W3 Total Cache
  • 9 Comments sorted by
  • Hi michal,

    I think it could be a porblem that striking is not in the themes folder anymore because of all the changes for the wp multisite. Could you please setup a striking in the themes folder and see if that clear cache generates the same error?

    Best regards,
    BackuPs
  • First of all I need to say that I use a child theme. I did set the theme in it's original directory and nothing has changed. I still get the warning, but then I switched from the child theme to striking and the Clear Cache option works fine. Now... I set the old name and it looks the same: if I clear cache while using the child theme I get the warning, if I use Striking I don't so it's rather something wrong with the child theme...
  • Hi Michal,

    I guess you updated the child theme aswell?

    Best regards,
    Neo
  • I just did but it got even worst now. I still get the warning and I have two Striking menus with double content.

    menu.png
    163 x 1925 - 39K
  • Hi Michal,

    Then how did you update the child theme? You should have removed the first one before updating.

    I will get back to you on how to commence on this later on to day.

    Best regards,
    BackuPs
  • I have replaced all the files except styles.css and I have moved 2 custom lines from the old functions.php to the new one.
  • I had the same warning and I also use a child theme. Here is my warning...

    Warning: Invalid argument supplied for foreach() in /hermes/bosweb/web252/b2524/ipw.ravenousravendesign/public_html/wp-content/themes/striking/framework/admin/options/theme_advance.php on line 25
  • so I followed these EXACT steps I found on another thread...
    http://kaptinlin.com/support/discussion/comment/18105#Comment_18105

    UPDATE: Fixed thanks to help by Websys:

    Problem was that I was using Striking-Child theme and this has to be updated to, if you disable the child theme, you'll see everything works, you can disable it, update child manually by downloading the latest release, and then reactivate.

    Disabled child, saw it was working, and then updated it with FTP upload, vim'd the version number to 0.6.0, i activated striking without child to do the cache clearing, it cleared without issue, switched back to child and viola, thanks

    And now everything in my website is doubled as is in this thread. uhuhuhuhhuhu
  • Hi Ravenous,

    We are working on the double menu items. As soon as we have a solution for that we let you know.

    Best regards,
    BackuPs
This discussion has been closed.
All Discussions