To insert code in a forum thread or comment wrap it in code tags : <code>...</code>.
  • I have successfully added all the strings to translate to my website but the 'striking - Search" widget always displays "Find" instead of the translated string. When you use the standard "Search" widget it translates the title correctly. I would rather use the Striking widget as I have a bit more control over the color.

    I have not found any other Striking widget that displays this behavior.

    This was originally posted in the 3rdparty widgets forum but after 2 days not a single view so I am posting it here
  • 11 Comments sorted by
  • Hi Waldo,

    The search is within the language file that came with the striking theme.

    If your wordpress is in english you can either open the php file that contains the search... string and alter it see

    widgets.php line 43
    search.php line 41
    searchform.php line 2

    or add your own language file for you language based on the pot file that came with the theme (see language folder).

    You need poedit.exe to create your language files from the pot file and start editing it. Save it according to the language settings in your wp-config.php

    Best regards,
  • Not exactly the issue. I am using the file located in \wordpress\wp-content\themes\striking\languages. All other strings translate from English to Spanish, just the 'striking - Search' widget title does not. Until I can figure out what is wrong I will just stop using the title and only use the edit field and search button (which do translate properly).

  • Hi Waldo,

    I just checked the es_ES.po which came with the striking theme and it has all the right settings.

    You wrote: "I have successfully added all the strings to translate to my website but the 'striking - Search" widget always displays "Find" instead of the translated string."

    What does this mean? There is already a es_ES.po file in striking or did you create another one or just altered it?

    It works perfect in my dutch site and i compared the two language files (spanish and dutch) with each other an i cannot find any difference.

    get back to me on this.

    can you attach the po file to this thread you used? I will try it on my website

    Best regards,
  • I am using the default es_ES.po file. I have made no modifications. What I did on my site was choose the 'striking - Search' for footer widget area 4. I added the title 'Find' so that it displays above the search edit box as well as the search button. I went to the WPML >> String translation and selected Widgets >> widget title >> Find and translated it to 'Encontrar'. Dumped all cache pages and then went to the English page first, then hit the Spanish (Mexican, in my case) flag. The result is that the title still says 'Find' but the edit field and button say 'Buscar'.
  • LOL. Does it work with all plugins disabled?
  • I cannot disable WPML since it will just make all my translated posts and menus fubared. But with every other add-on disabled it still acts the same way.

    Ignore the two More... buttons in English, I leave them that way until I have the page translated.
    850 x 384 - 23K
  • Hi Waldo,

    i have made a link in the striking 5.1.7 error section for this. Maybe Kappy has a idea.

    Best regards,
  • Has anyone else had this issue!

    I still cannot get a few strings to translate even after making sure all strings have been translated in the WPML >> String Translation admin page.
  • Hi WheresWaldo ,

    You can unzip the attached file to striking\framework\widgets folder to fix search widget title translation issue.

    What else strings?

  • Sorry it took so long to get to testing, but the file you supplied worked perfectly. I have not found any other strings that did not translate correctly.

    WheresWaldo (Bud)
This discussion has been closed.
All Discussions