Live Support by a Striking Team member to assist with forum questions is offline at this time.
To insert code use <code>...</code>.
contact form submit button not working
  • Hi
    for some reason my submit button on my contact page is not working, neither on the page form or the widget form
    http://sebastienchort.com/contact/

    I'm using striking 3.04 an wp 3.1.2

    I know I should upgrade but I heavily change some code on both wordpress and striking theme

    I wished to know if someone would have an quick idea or clue to fix it without upgrading, that would save me so much time and hassle.


    thanks
    Seb
  • 12 Comments sorted by
  • Hi Seb,

    I just check your site. And see you using a plugin for contact form.

    Let me know what's going on.

    Regards,
    KaptinLin
  • Hey KaptinLin

    right, I switch to use a plugin last week as I really need to get my contact form working.
    I will add the widget again in the footer if you want to take a look about the initial issue.

    let me know
  • Hi sebchort,
    When i try to access http://sebastienchort.com/wp-content/themes/striking/includes/sendmail.php it returns 500 Internal Server Error.

    So it's a permission issue. You can change the permission of 'striking/includes/sendmail.php' to 777 or 755 or 655 then have a try.

    Regards,
    KaptinLin

  • Hi KaptinLin,

    I'm also having problems with the contact form on my site I'm afraid (see http://www.matchlessclueless.com/). Nothing happens when you click the send button. If any of the fields are left blank when the button is clicked then they seem to become highlighted, but when all are correctly filled in and you try to send nothing at all happens.

    I also get a 500 server error when I try to access the sendmail.php file directly as you described above. But I have tried changing the permission of this file to all of the 777, 755 and 655 options you mentioned and this hasn't made any difference.

    Any other thoughts please?

    Cheers, James
  • P.S. I've also tried your other suggestion found in other threads of installing the 'Configure SMTP' plugin which successfully sent a test email message, but still no luck with the contact form I'm afraid :(
  • Hi En7Jos,

    Can you send us login details for the admin part and ftp. Just click on my name and on the left you can send me a private email.

    thanks,

    Best regards,
    BackuPs
  • PM just sent, thanks BackuPs :)
  • I've also just tried setting up a contact form on a page (as opposed to in the footer / sidebar) but sadly the same problem still. The form shows up fine, but nothing whatsoever happens when you click the submit button.

    Any ideas please? Thanks, James
  • Hi
    We are working on this. Just be patience please.
    Best regards,
    BackuPs
  • Hi,

    The contact form seems to be working now in that I receive the message through via email, but there is no confirmation for the user that the message has actually been sent. Still nothing appears to happen when you click 'send', although it does in fact now send the message. I am assuming that it would normally come up with some king of ,message sent' confirmation, right?

    Is this something you are still working on, or do you have further suggestions for what I need to do to resolve this?

    Cheers,
    James
  • Hi James

    We are aware of the message not showing up and stil working on 5.1.8 new features.

    Best regards,
    BackuPs
  • All seems to be working perfectly on the contact form front after upgrade to 5.1.8 thanks. The 'message sent' confirmation now shows and the email arrives in a few seconds - great!

    Thanks, James :)
This discussion has been closed.
All Discussions