12 JULY 2014 - UPDATE

1) We have just released Striking 5.3 maintenance update for those still using the "Original" Striking theme. Please see the theme release thread below for details. This update is only available by the internal update function as this theme is deprecated and no longer available for sale.

2)  Next inline in a few days is Striking MultiFlex. This update is actually "in the can" but we are working on ancillary matters. Expect it sometime in the next few days.

To insert code use <code>...</code>.
SERVER PERMISSIONS! HOW TO ADJUST YOUR HOSTING IF YOUR SETTINGS/SLIDERS NOT WORKING 7 APRIL/11
  • Part 1:

    YOU MUST HAVE LINUX HOSTING IN ORDER FOR STRIKING WORDPRESS THEME TO WORK. IT WILL NOT WORK WITH WINDOWS HOSTING. IF YOU HAVE WINDOWS HOSTING, YOU SHOULD ASK YOUR HOST TO SWITCH YOU TO LINUX HOSTING.

    If you find that either your general settings such as color changes, or everything is working other then the image loading into sliders or posts, then you most likely have an issue matching your host server permissions, or other host related issues. Host problems are not a theme issue, but rather you understanding how you manage your theme in your host environment. Please read on, as this is a how-to for when you have these issues.

    Striking makes use of timthumbs as the management tool for "on the fly" image loading & resizing. Timthumbs is a great php script, but it does come with one headache - different hosts have different security permissions in place which may effect how it works.

    Here is a cutout of a great article which extensively discusses permissions and other issues that can effect your theme. Its from another themebuilder, and their customers have the same problem.

    ------------

    ""Troubleshooting Timthumb
    One of the most common problems users have with themes is getting the thumbnail resizer to work. This is usually due to a few common misunderstandings, but can also result from more ambiguous problems.

    1. Have you created your custom field correctly? (Not so applicable to Striking users unless you have created new Custom Fields)

    Make sure to read the readme file that came in your theme's ZIP file and follow the thumbnail custom field creation instructions. In most cases you will need to create a custom field with a Name/Key of "Thumbnail" (this is case sensitive) and a Value of your image URL. Some themes also require multiple custom fields to be created, usually for Featured Articles. In this case you would need to create a second custom field, as outlined in the readme, for all featured articles.

    2. Are the images hosted on your domain?)

    The timthumb script requires that all images being resized be hosted on the same domain as your WordPress blog. This is a security measure put in place by the author. If you are trying to use images from an outside sources it will not work.

    3. Does your cache folder have the correct permissions?)

    You need to give your /cache/ folder full permissions. In most cases this is "777" but it may vary depending on where you are hosted. If 777 does not work, try 755. It is recommended that you contact your host about what permissions to use if you are not sure. Settings permissions is also known as CHMODing, and can be done using most FTP programs and hosting control panels.

    4. What path are you using for your thumbnail image?)

    In most cases using the full path to your image should work. For example, you would input http://www.mydomain/blog/wp-content/uploads/image.gif (or whatever the path to your image is). However, some hosts do not allow the use of http://www. at the end of a URL. In this case you should use the relative path to your image, and remove your domain from the URL. In the above case, assuming your blog is hosted in the /blog/ folder, the path to your image would just be: wp-content/uploads/image.gif.

    5. Is your site using www.?)

    Within wordpress you can change the URL of your site. Sometimes this involves removing the www. from your URL, in which case all visitors directed to http://www.yourdomain.com would be redirected to http://yourdomain.com. Go to your website and type in the full URL: http://www.yourdomain.com. If it redirects, and removes the www., then you should also remove the www. from your thumbnail image URL's. (the ones you placed in the url path)

    6. Is your image extension valid?)

    A few times I have seen users that have images with the wrong extensions. For example, a PNG image has been saved with a .JPG extension. This can confuse the script. Make sure that your image have the correct extensions. To figure out what extension it should have, type the URL of your image in your browser and view the image. Right click it and choose "Properties."

    7. Does your server have the GD library compiled with its version of PHP?)

    This script requires the GD library to be installed. If your thumbnails are not working, check with your host to make sure that you have it.

    8. Does your server have mod_security settings that are impeding the scripts functionality?)

    Some servers may have mod_security settings that will stop the script from working. You should always contact your host if you are having problems to make sure they do not have settings enabled that would stop the script from working.

    9. Is the image you are trying to resize HUGE?)

    If the source image for your thumbnail is very large in resolution your server might not have enough memory to create the cached image. This often occurs when people try to use a 8+ megapixel photos. Try resizing your image down to around 500px in width before adding it to the custom field if you are experiencing problems.

    10. Are you using the latest version of the script?)

    Make sure you are using the latest version of timthumb.php. If you downloaded your theme a long time ago, try re-downloading it and re-uploading timthumb.php, or simply grab the source code from Darren.

    11. Are you hosted with HostGator? (this is not only true of Hostgator but also other hosts).)

    If you are hosted with HostGator then you will need to contact them in order to get thumbnails to work. By default, as mentioned above, they have mod_security settings enabled that do not allow the script to function. Also, HostGator does not allow 777 permissions. Instead, you should CHMOD your cache folder to 755. Also make sure that timthumb.php is set to 644.

    End of Article
    ---------------------------------------------------------------------------------

    IMPORTANT: See Part 2 below
  • 35 Comments sorted by
  • PART 2 OF PERMISSIONS

    We add to this the following:

    a) you are often best to adjust permissions from your host file manager, not ftp. Depending on host, you may only be softcoding your permissions but server side nothing is happening. This of course is very frustrating as you don't know it is the case until you log into your host.

    You also need to have your wp-admin open, as you may get messages telling you that certain folders or files are not writable - effectively this is WP telling you host requirements.

    Be aware that when you are adjusting permissions via the host file manager, you may have to log out first, then refresh you webpage, to see if it is working. Its a slow process. Go to file manager, change permission, log out, refresh page to see if slides show, go to file manager, change permission, log out, refresh, and so on. All the while also refreshing your wp-admin so you can see if you get any wp messages about non-writable folders/files.


    Always start with a basic permissions set:

    All files at permission 644.
    All folders at permission 755

    Then if not working, change permissions usually on
    striking/cache to 777
    striking/cache/images to 777 (note that you may not see this folder initially, wp creates this automatically)
    striking/cache/skin.php to 755 or 777 (this is rare)
    striking/includes/ timthumbs.php to 755 or 777


    b) the newest version of Striking will always use the latest version of the timthumb script so updating timthumbs is not something you need to worry about unless you are using an old Striking version.

    c) on rare occasions, it may be necessary to adjust the permissions on 2 files found in the framework/helpers folder:

    optionGenerator.php
    themeGenerator.php

    from 644 to 755

    d) in a very few instances for some hosts using the php 5.3 above, you may need to add a "cache" and "temp" folder to the includes folder where timthumbs.php resides, with the same permissions as the timthumbs.php file. I have only seen this once, and it was unique to the host the striking user was using. But you could be that 2nd instance and there are posts on the net about this.

    e) Having the cache and associated files and folders with a potential permission of 777 does not compromise your security in any extraordinary way that we are aware. Far more dangerous, and the usual target of all websites is their logins. These are often attacked by brute force. We suggest using the Login Lockdown Plugin from wordpress.org. It shows as not having been updated since WP 2.8, but it works right up to WP 3.1. There are other security plugins as well, that you can use to protect your site.

    f) This was pointed out in a thread recently:

    http://kaptinlin.com/support/discussion/comment/4206/#Comment_4206

    and also today just caused another user a great deal of grief. If your domain name has the tilde character: ~ in the domain name, or even in a file path, this is incompatible with the timthumbs script used for automatic image resizing, and your sliders will not work. The tilde symbol is classified as a special character - it defines the base directory in scripts, so it cannot appear in url / file paths.


    As the article above indicates, you should probably talk to your host, they know how they have set up their permissions, GD library and mod_security settings, and almost certainly will know from past instances what works for timthumbs in their hosting environment. One thing to definitely ask them if they have the PHP "readfile" filesystem function disabled, or with particular security permission.

    Searching Google for timthumbs problems turns up many links, virtually all variations of the above. So if you have tried the above (and I think for many the first thing they should do is ask their host about the issue), KaptinLin is a whiz with this issue, I think he has a feel for it. I succeed about 50% of the time on a good day. For 90% of you it will never be an issue. For the other 10%, you will, as some users have said recently, want to trash your notebook, pull your hair out, and kill someone.

    So don't. Kappy is always backed up - but he does get to them all within 2-3 days except in extraordinary circumstances.

    Happy Striking
    Websys
    James
  • I encourage others to post about what worked for them, and the host. Last night one of the ones I fixed was on a German host (everything was in German which I neither speak nor write).

    Anyways, I fixed it. Permissions were wrong and the user had loaded up images for slides, but not set any of them as a featured image. So it was the double whammy. I could see when I went into the host file manager that they had tried many permissions, as they had varying permissions on different folders/files. So kudos to the user for first trying - it turned out that they had set many of the permissions to high.

    It was a host where one had to log out of the file manager after each adjustment, very annoying.

    Configuration that worked
    All folders set to 755
    All files set to 644
    Cache folder, images subfolder and skin.css all set to 777

    So in the end, a configuration very close to baseline.


    I originally thought that a problem was related to the fact the hosting was another reseller, and so hosting was via a subaccount, with hashmarks in filepath, since the on the fly image resizing script is sensitive to odd characters in the file path. Thankfully my "panic" on that issue turned out to be needless.

    But do be careful of hosting resellers where you are pushed into a subacounts for hosting. Its always more difficult to setup, and resolve problems in that environment. Get primary hosting.

    Websys Team
    James

    PS - The process did inspire me to add more information to Part 2 Section A in the permission guide. I guess as we encounter diff situations, it will always be a work in progress....
  • Updated today with "f" above on the Tilde sign. This regretfully has cost a user much pain, as their host only works with the tilde sign for temporary domains (I think is a temp domain, or 2nd level domain) and timthumbs php does not allow the tilde sign in filepaths.
  • Updated today with more detail.
  • The Websys Team is totally awesome! This is my first time installing a template and I thought I messed things up pretty badly that I needed to reinstall word press. And just after I posted my problem, they responded quickly, checked out my settings and let me know what was going on. This is defintely the best customer service experience I've had online or offline. Thank you so much for your excellent service!
  • I am a word press newbie and this was my first theme install. I thought i would share my experience with this and maybe safe someone else the time.
    After my install of word press i followed the instructions to upload striking.
    I also uploaded the demo. ( I agree the demo should be put on a local server)
    There was not a thumbnail in the theme window and when i activated the theme my site was only a directory.
    I will not go into the details of uninstalling WP 3.1.3 and reinstalling WP 3.1.2
    Messing around with WP-config.php and MySql.
    I changed some file permissions on server (cache and timthumb.php) with no luck.

    I called my host tech support and he noticed the permissions of the uploaded striking folder was not set properly on upload. (Lunarpages is my host)

    Started as:


    image


    Changed to:

    image
    cameas.png
    563 x 196 - 87K
    shouldbe.png
    576 x 218 - 80K
  • Hi everyone,

    I spent two days trying to figure out what was causing the problem here, and am happy to have an answer.

    Striking Slideshow Fix

    The issue was being caused by the options in the Advance menu.

    Combine JS
    Combine CSS
    Move JS to bottom


    Set all to off!

    Cheers,
  • solved by installing version 3, deleted my post
  • George71 said:

    solved by installing version 3, deleted my post




    OMG - THANK YOU ! ! ! ! ! ! ! ! ! ! ! ! ! ! ! ! ! ! !


  • I contacted my host and we changed everything to 777 and still it's not working :( It's driving me mad. Can someone please help me?????
    ------------------------------------------
    Update:

    Okay I started working on my husband's newer laptop and everything seems to be working. Thanks again for your support. Now this is probably just a WordPress issue I'm not familiar with but I followed the same steps with adding my first slide to create my second and it's not working. Tips?

    Thanks again!!!
  • Are you using W3 total cache? I updated everything to latest. if I turn off
    Combine JS
    Combine CSS
    Move JS to bottom
    does W3 take over anyway? Did that fix your slider issue? I use Hostgator VPS4. I use W3, maxcdn and memocache. I have slider problems, comment box in post problem (before it was set at anyone can comment and there was just a comment box then after updating everything the comment box is now "Leave a reply" asking for name, email, website and comment then when you fill out it just shoots you to top of page and does not accept comment. I have comment on in striking and in WP I have anyone can comment. Posted of course after mediation.
    I also have a tImthumb problem with slider?

    also this .css style .css cache appeared out of nowhere?
    http://boracaylive.com/wp-content/themes/striking/cache/3cb0a3444afb172832c466684fa983e7.css

    /* theme-style: (http://boracaylive.com/wp-content/themes/striking/css/screen.css) */


    /* theme-skin: (http://boracaylive.com/wp-content/themes/striking/cache/skin.css) */

    happened when I upgraded to WP 3.2.1- what a pain - I log in and the cache changes on this style pages leaving my site with just text and images no theme or skin. I have to clear page cache and put new cache link in minify in W3 to fix the problem - what a pain!!!

    Any help would be appreciated! I cant really tell if the problem is caused by WP upgrade or W3? I shut off W3 and problem still persist. I believe W3 actually adds stuff to .htaccess. In Timthumb I added allowed sites my url and my cdn url. No change!
  • Our site went down the other day. GoDaddy said they did a restore but none of the sliders are working that were all working before. We checked and had them reset the security settings as this post recommended but still can’t see any sliders. It’s strange since we didn’t change anything. Anymore suggestions? We’ve been down for several days now and need to get back up soon. Any help would be greatly appreciated.
  • Hi demo38

    Can you advise if you are still having problems? If so please message me with your wp admin and your host logins, and I will go take a look. Click on my name, and you will go to my page. Then you will see the option to send me a personal message.

    I hate godaddy, my last experience helping someone out on this issue there I recall was a brute. But it can be resolved. It was months ago, so I can't remember what I had to do. But I certainly will give it a try for you.

    Best Regards
    Websys Team
    James
  • I have a lot of issue with slideshow, I have contacted my hosting company Godaddy I was told by the tech I need to switch to Linux instead of Window therefore I can get have write permission! Backing up the server and moving to Linux now, anyone have a feed back with this issue? Using latest Wordpress!
    ------------------------------------------------
    Update:

    I'm using Linux on Godaddy and able to have one image working in the slider but when adding more nothing showed up! Yes I set the all the images as featured images for the slide show.

    http://3dVancouverWedding.com
  • Hi there, I am in my first 24h using striking and got stuck with images not showing in the slideshow.
    Followed debug instructions in this post and found that plugin "Post Types Order" http://www.nsp-code.com/ (v.1.4.9) breaks the slideshow (striking 4.0.2, wp 3.2.1).
    Just by disabling the plugin, slideshow works again.
    Hope this helps
  • Hi all,
    I was driving myself crazy trying to get the thumbnails to work ... checked all the permission issues, libraries, etc, etc ... and I finally was able to make it work by modifying the timthumb.php as per http://www.binarymoon.co.uk/2010/08/timthumb/ entry of 28Jun11.
    I included date_default_timezone_set('Europe/Madrid'); right in line 155, after public static function start(){

    and just with that worked for me in 4.0.2.

    ps. I am reposting this in the error reporting forum, as while this might not be exactly a theme error, but upstream or config issue, it's probably worth to have the developers take a closer look at it
    ----------------------------------------------------------------
    Sept 13

    Very interesting on the post order types. the theme is designed to work with that plugin - which is one of kappy's favorites, and to date we have never had an instance of this problem, to my knowledge.

    we may need to get further info from you at a later date if you don't mind.

    Thanks
    James
  • I had exactly same problem, no feature images and no slideshow images at all. Then I found useful disabling all plugins one by one.

    "Import Users to MailChimp" was the problem. Once disabled, everything works now!

    http://wordpress.org/extend/plugins/import-users-to-mailchimp/
  • Wow ... Got the issue too when I tried to install it on my hosting provider; none of the image thumbnails nor slideshows (JQuery Nivo/Striking or WP Nivo) are working on this liinux installation (new one WP 3.2.1 at GoDaddy.com).

    Tried with Striking 3.0.6 at first (that is the one running OK on my local pc for testing) and also with the just released Striking 4.0.3.
    I tried many of the suggestions in this long post and *could not get it to work* as of yet.
    Any development for the other folks on godaddy linux installations?

    Anyone could look at my installation? That would certainly help as I seem to be stucked at this point and cannot put this in production.

    http://www.mechantgrosminou.com.previewdns.com (and yes it is in french :-) )
    ------------------------------------
    Oct 6
    oups ... I had a false hope here. I thought it worked but it is not. Only working on my local installation. Still cannot make it work on GoDaddy.
    -----------------------------------------------

    Oct 11
    To anyone on godaddy.com: you *cannot* make timthumbs and Nivo Sliders (all) work in the previewdns.com zone. previewdns.com is a domain godaddy uses for customers who need to sandbox the website before putting it in production (let say, like myself, that you are in the process of replacing one site by another). Sliders are working fine in the production environment after (before I am not sure) I made the suggested changes. Case close here :-)
  • Thanks for this info. I worked my way through the entire list and eventually found that adding a folder "cache" with permissions 777, in same folder as timthumb.php script, solved the issue. Slider now works perfectly. I would never have worked that out on my own. This is with version 3.0.5. Didn't need to upgrade, though I plan to. Hope this helps someone else who is tearing their hair!!
  • Websys said:

    I encourage others to post about what worked for them, and the host. Last night one of the ones I fixed was on a German host (everything was in German which I neither speak nor write).

    Anyways, I fixed it. Permissions were wrong and the user had loaded up images for slides, but not set any of them as a featured image. So it was the double whammy. I could see when I went into the host file manager that they had tried many permissions, as they had varying permissions on different folders/files. So kudos to the user for first trying - it turned out that they had set many of the permissions to high.

    It was a host where one had to log out of the file manager after each adjustment, very annoying.

    Configuration that worked
    All folders set to 755
    All files set to 644
    Cache folder, images subfolder and skin.css all set to 777

    So in the end, a configuration very close to baseline....



    This worked for me!!! Thanks
  • no thumbs... have tried all of this ... so now to host support which is always fun ... notamuseddotcom8|
  • If it helps somebody - I was really pissed in a long time, until I set includes/cache to 755 and includes/timthumb.php to 644 !
  • Hi markc78

    message me if you are having problems. Your host should be able to tell you what is necessary one would hope!

    @ PeterPlys
    your situation is yet another example of how widely permission settings can vary from server to server. 644 permissions working for timthumbs.php is normally quite rare these days.

    Literally, we ask that users understand that if their are 1 million web hosts out there, then this means there are likely 1 million diff sets of host permissions. Its a pain in the ass to determine which is correct.

    Best Regards
    Websys Team
    James
  • Hi guys,

    I've just updated to 5.0.1 and have encountered the sliders not working for the first time ever. I have updated all my permissions to the recommended settings but still nothing!

    Any ideas?
  • Update, I have not installed new 5.0.1 yet.

    The fault in the theme is actually from Wordpress itself. The reason I say this.
    I had gator remove everything from the domain. I uploaded an older version of striking I know worked fine minus tag cloud or blog. Adjusted the perms. Still nadda.

    Also people, do not turn on "supercache" until you have finished working on your site. Turn it back on after your done for the day.
    The reason is, you will stonewall yourself with a site that does not change. Due to being unable to refresh browser. It will stay the same regardless.
  • Hi,
    I have read this discussion top to bottom. Can someone help with:

    Just upgraded to 5.0.1 and my slider content disappeared. Captions and controls are still there, but no photos.

    I have adjusted the following to 777:
    -striking/cache
    -striking/cache/images
    -striking/cache/skin.php
    -striking/includes/ timthumbs.php
    and the following to 755:
    -optionGenerator.php
    -themeGenerator.php

    Sliders are still empty. Can someone offer some help?
  • aether59, the exact same has happened to me! Someone please help?
  • Hi aether59 and jmunto11,

    Can you email me with this issue?

    Just give me a wordpress login and ftp info. I will help you check the issue.

    My email is kaptinlin@gmail.com

    Regards,
    KaptinLin
  • I contacted my host (SubSys) and it seems they had blocked TimThumb on server level because of the security glitch of the previous version. They unblocked it for me, and will do so for everyone who have updated to the most recent version.

    Problem solved.

    Thanks for your help.
  • I have also adjusted the following to :

    -striking/cache to 777
    -striking/cache/images to 777
    -striking/cache/skin.php to 777
    -striking/includes/ timthumbs.php
    and the following to 755 and 777 (tried both configurations)
    -optionGenerator.php to 777
    -themeGenerator.php to 777
    -created a "cache" and "temp" folder in the includes folder.

    Does anyone have any suggestions as to what I should try next.

    I've been in contact with my host, and I am on a shared server with PHP5 and GD Library enabled.

    Would really appreciate any help.

    Many thanks

    GeminiTKD
  • Thanks for the wonderful mini-tut it stopped me from pulling out the remainder of my hair:)

    I am hosted on hostgator following the directions:

    11. Are you hosted with HostGator? (this is not only true of Hostgator but also other hosts).)

    If you are hosted with HostGator then you will need to contact them in order to get thumbnails to work. By default, as mentioned above, they have mod_security settings enabled that do not allow the script to function. Also, HostGator does not allow 777 permissions. Instead, you should CHMOD your cache folder to 755. Also make sure that timthumb.php is set to 644.

    Contacting Hostgator support to have them look into the problem since, the slider images were still not showing in the slider. What they found was that Cloudflare was causing the problem.

    For those using Cloudflare on a host gator server do this:


    Tends to be due to the RocketScript function in CloudFlare. You can find this feature documented at http://www.cloudflare.com/wiki/Rocket_Script

    Disable this feature to see if the issue resolves, and then (as I'm pretty sure this will fix it), you'll likely want to file a bug report using the link on the previously mentioned page.

    How to disable this feature: http://support.cloudflare.com/cgi/kb/cloudflare-website-optimization-and-speed-features/how-do-i-turn-rocket-loadertm-on-or-off

    Once you do that the slider images appear like magic
  • I am running a Linux server hosted on GoDaddy and none of these steps seem to be working. When calling GoDaddy, they don't even seem to know what I'm talking about, even speaking with their Wordpress database "experts".

    Is anyone out there also running Linux servers on GoDaddy and got the sliders to work?

    FYI, pictures are set as featured images, sliders were working before the update to Striking 5.1.

    Thanks
  • Does anyone have any concerns regarding these permissions? I've been told by numerous people that no directory should be set to chmod 777. Thoughts?
  • Joel said:

    Does anyone have any concerns regarding these permissions? I've been told by numerous people that no directory should be set to chmod 777. Thoughts?



    Hi Joel,
    The permissions needed are actually entirely dependent upon your host and how they have set up their hosting servers. In this day and age, more hosts have reworked their server settings so that 755 permissions are fine, and sometimes even less. When Striking was first released 2 yrs ago, hacking activity was not at the level it is now, and in fact 777 was the standard for caching and timthumb was the standard image resizing script.

    This is no longer the case, timthumb is still included in the theme, but any user since the commencement of the 5 series of Striking can turn their timthumb off, and for new users, it is off automatically, and we use an internal script based on wp core functions instead. As a result, 755 permissions tend to be the standard, and on some servers, even lower permissions work fine.

    Best Regards
    Striking Team
    James
  • Good to know 755 is fine most likely. I just loaded Striking to my theme folder and was unsure also to change 755 to 777. Will change it back to 755 and see what happens. My host is BlueHost.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion